Database timeouts
Resolved·Partial outage

This incident is resolved.

Tue, Sep 2, 2025, 05:42 PM
(1 day ago)
·
Affected components
Website
API
Code Analysis
Code Coverage
Updates

Resolved

This incident is resolved.

Tue, Sep 2, 2025, 05:42 PM

Identified

We have identified the cause of the database timeouts to be an attempt by our cloud database provider to upgrade the version of our database server. During the attempted upgrade, the database exhibited unacceptable performance. The upgrade is being reverted and we expect to return to normal operations shortly.

Tue, Sep 2, 2025, 05:24 PM(18 minutes earlier)

Investigating

Queries seem to be timing out again, investigating.

Tue, Sep 2, 2025, 04:46 PM(37 minutes earlier)

Investigating

Queries seem to be backing up again, investigating.

Tue, Sep 2, 2025, 04:46 PM

Monitoring

The database timeout errors have subsided and we are continuing to monitor and investigate

Tue, Sep 2, 2025, 04:29 PM(16 minutes earlier)

Investigating

We are investigating an increase in timeout errors when querying our database.

Tue, Sep 2, 2025, 04:12 PM(17 minutes earlier)

Identified

We are receiving a number of timeouts errors, investigating.

Tue, Sep 2, 2025, 04:10 PM