Resolved
This incident has been resolved.
Identified
We are currently investigating delays in Code Coverage processing.
Coverage uploads that require mapping commits to pull requests may be delayed due to degraded performance in GitHub’s Pull Requests and Search APIs. This can impact the timely delivery of coverage statuses and comments on pull requests.
Analysis processing is not affected. The issue is limited to coverage ingestion and reporting.
We are actively monitoring the situation and will provide updates as GitHub recovers.
For more information, see GitHub’s status page: https://www.githubstatus.com/